Table Extraction next page navigation not working

Can someone please help me with my issue on how to navigate to another page ?
I already enabled the extract to multiple pages and locate the next button but it only extract the first page and not proceed to another page.

Thank you

Hi @jovarie.inoc

Once you click in the extract data from multiple pages, UiPath will request to map the button which will navigate to the next page, you must ensure that the selector is realiable, so please check the selector and check if you are mapping the correct element


Thank you for your response.
I managed to edit the selector and it successfully navigate to next button but the another problem is that
I need to scroll it down myself so that it will locate the next button.

Is there any other way that it will automatically scroll it down by itself without my presence ?
BTW, it will stop the scraping up to 9 page but the total page is 100.

I would really appreciate your help.

Thank you.

in your use application/browser activity, use the input mode property as Simulate

And in your extract table activity, use the input mode as Smae as App…
Also set the Limit extraction to no limit



use inject js to scroll down, you can use my workflow to get the bot to scroll all the way down before you call “table extraction”
Scroll to bottom - Copy (1).xaml (11.0 KB)
download these scripts and put them in the same folder as the xaml above
scrollToBottom.txt (64 Bytes)
checkIfScrolledToBottom.txt (132 Bytes)

logic of the workflow is

  1. scroll down (call scrollToBottom.js)
  2. check if at bottom of page (Because some pages load more rows when you scroll down) (call checkIfScrolledToBottom.js)
  3. if not at bottom, scroll down again

in the workflow remember to change the selectors of these 2 inject js activities (change to selector to element in your own page)


I tried your suggestion and then this

warning was displayed and when I tried to change the “Click before typing” to none then the warning was gone but when i tried to run the project, it doesn’t type the username or email on the input.

Help me please,

Thank you

Hi @jovarie.inoc

Set the Click before typing to None


Hi @jovarie.inoc - It was not able to type as the click before typing is set to Null. Can you go back to Use Application/Browser activity and set the input mode to Hardware Events , then set the click before typing to single and check how it goes

Since it was not going to down automatically going down, did you try using Mouse Scroll activity

Thank you for your response.
It was solved.

I replace the activities. Instead of app/web recorder, I add the activity one by one needed for automation.

Thank you all for those who replied my issue.

Best Regards,

1 Like

Thank you for your response

Thank you for your response.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.