How had been chaged setting new "Extract Table Data" menu in 2021.10.4?

When I try to use the extract-data table action in UIPathStudio 2021.10.4, I cannot move the page even if I set the Next button on the browser to move the page. Please let me know. Please let me know.

Hello @pchan0325 ,

Can You please share the full link to the website with the data table You want to extract?

I tried with “マー - Google Search” (as much as I saw from the screenshot) and it seems to work correctly, data from all pages was extracted, but it would be best to try with the full link.

The code I tried is below:
ExtractStructuredData.xaml (14.8 KB)

Thank you. this is same xaml in my project. but they never move to next page.
for example Serching kyeword of “UiPath”. Comunity version dos’nt work now.but old data scraping can move to next page.
today I made again, it was move to next page.
thank you. it was bag??

Great to hear that :slight_smile:
I see You are using fuzzy selector and image to identify the button that has to be pressed in order to move to next page.
If for some reason a selector from object’s attributes can’t be used other options seem perfectly reasonable.
I don’t believe any solution that works is bad, it’s usually just a good idea to decide what exactly do we need and in what conditions does the tool need to work.

1 Like