Swagger Service: Service operations are not found

Hi,
in an internal software I have got a REST interface with a swagger description. It works fine with a “direct” http connection.
I would like to use the Service capability and load the yaml file. It loads, but doesn’t save all of the available options: I get the message “Service operations are not found”

If I uncheck all the options with a hyphen “-” in the “path” section, the file is saved.
If I delete the hyphens in the yaml file, the complete file is saved.
The developer of the interface insists, that hyphens and underlines are valid characters in the YAML files.
We can’t simply change the paths in the interface, because there are other comsumers of the interface.
Has anybody an idea to solve this situation?
YAML file is uploaded.ap1337-yaml_fuer_support.7z (4.1 KB)08-10-_2019_09-03-17

Hi @jodroenn

Thanks for the report, I registered the bug in our system. I will update the topic after someone from our team had a look :slight_smile:

Hi @jodroenn

This was fixed by our team. The change will be available in 2019.10.0 beta builds higher than 312 :slight_smile:
(if not available yet, it will be soon :slight_smile: )

Hi, thank you very much.
I tested it with beta 331 and it is working fine :slight_smile:
It works now with paths including hyphens.
I have got a similar case where the path contains underlines - it doesn’t work yet.
Should I open a new topic for it?

1 Like

Hi @jodroenn

Could you post a screenshot of the path that doesn’t work? I suppose you mean this character?

_

Also, are there any other ones that make it not work?

Hi,

yes, that is the right character that doesn’t work too .

As far as I know, the problem is with – (hyphen or minus: now fixed) and _ (underscore: not yet fixed)

Thank you,

Joern

1 Like

Thanks, we’ll take care of this one too :slight_smile:

Thank you very much, have a nice weekend

Hi @jodroenn

Could you maybe provide a YAML file that reproduces the issue?
It seems to work when our team tried to reproduce it.

Hi Maciej,

please find the attached YAML and XAML files.

There are 4 blocks in the service:

  • Auth, patch and rest_bmc_patching are working,

  • Srv not

Many thanks in advance,

Joern

AUT-262_Infotool_ap1283.7z (63.5 KB)

Thanks, we’ll keep you posted :slight_smile:

I believe this issue should be fixed now. Could you give it a try? :slight_smile:
(on the latest beta 2019.11.0-beta2)

1 Like

Dear Maciej,

Many thanks,

Sorry, I will come back to you in the next days.

I am too busy at the moment.

Kind Regards

Joern

1 Like

Dear Maciej,

I am afraid it is still not working perfectly. I can’t see a difference as it was before.

I use the Beta:

image001.jpg

I can use this 3 parts as before:

image002.jpg

But the last part doesn’t work still:

I would appreciate a solution, so I would be able to build a library for these connections.

Thank you very much

Mit freundlichen Grüßen

i.A. Jörn Droenner

Ressort Innovation & Infrastruktur

Fachgruppe Monitoring & Automation

image003.png

BTC IT
Services GmbH

Escherweg 8

26121 Oldenburg

Tel: +49 441 36192-1741

Fax: +49 441 36192-1799

E-Mail: Joern.Droenner@btc-it-services.com

Web:
www.btc-it-services.com

Hi @jodroenn

Please try the latest 20.2.0-beta.108 version. It should be fixed for good by now.