Studio Publishing version number is not detect well

I have the studio 2019.10.2 and orchestrator 2019.0.14. Already I have the process with version 1.0.4 . When I publish the package it shows the current version 1.0.0 and new version 1.0.1.

Note :

  • I have restarted the UiPath Robot.
  • I have opened the Studio RunAs administrator.

Thank you

@balupad14 - a quick test - manually update version number from 1.0.1 to 1.0.5 - by typing in to the New Version text box. This will allow you to use the 1.0.5 package on orchestrator.
Subsequent builds should automatically have the correct version number.

1 Like

Yes @sumitd.

Manually if we changed. it is working. Each and every time we go to see the version number in the process… we have nearly 200 process…


@balupad14 - you need to create a bot to do those 200 bots :slight_smile: (kidding!) For me, this happened with one process, and after I changed the version manually one time, it worked as usual the next time.

Not sure, what might have broken the link (or something).

@bcorrea @Palaniyappan - suggestions?

1 Like


I guess you deleted project.json file for this process and opened the project right ?

1 Like

Hi @lakshman,
yes. for one project . we can do it. but we have more than 200 ???. We are analyzing to fix it some other way…

Thank you.

Hi @sumitd,



I also faced this kind of issue recently.

We recently updated Uipath studio to latest version 2019.10. When I tried to open old code into new version and its not opening. So I deleted project.json file and opened the xaml file. Then the version number becomes 1.0.0 in project.json file and I changed version number manually into the file but still it’s showing 1.0.0 only. So, I updated version number manually at the time of publishing process and it’s worked fine.

Hi @lakshman,

Wanted to ask, are you still updating the version number manually at the time of publish? or you have found another workaround for this already?

Asking as I am facing the same problem.