Studio error when I execute any workflow

After some Windows Update the UiPath Studio started to raise this error message when I try to execute some workflow.

Here is the screenshot.

I have already tried to reinstall Studio, but I still got the same error

What version of System.Activities and UiAutomation.Activities do you have (in Manage Packages).
(you can also see versions in dependencies section)

I seem to remember those packages can cause errors similar to this.

I’ve tried to start Studio again to se the packages and it starts to throw another message error when I try to update the packages

I’m just guessing but I think maybe you have a dependency needed for that workflow but it’s not found in Manage Packages for some reason.

I would suggest opening Studio without opening a file. Then, check your sources in Manage Packages and make sure you can see everything ok and install the packages you need, like the Web package that contains the json methods.

Then, copy your .xamls into your new project > click refresh in the Project section in Studio so it updates your copied files. Then, try opening one of your files from the Project section inside Studio. If you don’t have all the dependencies installed, you will get errors in red in the Output pane. so, you will need to resolve that by installing activity packages which are needed. After resolved, close your other Main that was created when creating a new project and delete it since it was just temporary.

I don’t know if that will help, but hopefully it does. Regards.

thanks for your answer, Clayton.
But this new message error appears at the moment I open the Studio. It’s not opening any workflows.

Try clearing the Studio cache here:
you can delete all the files there. (you may need to close everything UiPath first like the Studio and Assistant.

Then, try opening again.

Sorry, the cache might be in the Local folder instead of Roaming:
I think you can delete everything except any app folders where Studio is at.

Hi Clayton, tnks again
I did that, and I still get the same message error :frowning: