Start Process with ".appref-ms" extension


how can I start process with “.appref-ms” extension?

Thx for any suggestions.
Kind Regards,


You have to give the executable in first and the file path in the second…to find exe open the application and open task manager


Hi, @Anil_G

thank you very much. I do not understand “to find exe open the application and open task manager”.

I solved it that way:

  • opened File Explorer with W+e
  • entered filepath and
  • double clicked on the filename.

Kind Regards,

1 Like


Let me give you an example…say you want to open a website …ideally you can use open browser or use application…

But instead if you want to open using startprocess…in the first field chrome.exe locationis given and in second field the url is passed

So similarly if you need to start a application from file…first you need to identify the exe file neededfor that …

How you can find is by opening the file manually and check which executable or exe is used and pass that in start process…

For eg: if you want to start a .jar file which is a java application…so first argument would be java.exe and secomd one would be the .jar file

Hope this is clear


So I tried something similar earlier today (using Start Process and passing through the path to CMD with the path to my bat file as an argument) and it completely disagreed with me. I couldn’t get it to work until I started the bat file directly.

I had a similar problem with the BlueStacks application over the weekend, so instead, I used “Open Application”, selected the window of the open application and that worked.

My suggestion: If you are trying to run a command, rather put it into a bat file and run the bat file directly:


For bat files you have to run directly only…for anythiing to run directly in cmd you have to give it directly in the first itself.

basically start process starts the cmd already

Hope this helps


Yeah I found a post saying the same on the forums so I tried it and it didn’t work which is why I resorted to this.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.