Start Process: Application could not be opened

I am getting an error when using a Start Process activity to open an Excel file. The Excel file opens fine but I still get an error saying that the “Application could not be opened.” I tried doing it in an Excel Application Scope activity as well but the file doesn’t open with that. It’s a blank file so I don’t think it should be an issue.


You can use the full path of the excel file along with filename that you want to open in the start process: FileName property and this should solve the issue,

let us know if this helps,

Pavan H

I have the same problem. It worked well, but suddenly this error message :frowning:

HI @sducey95 & @Sajuri ,

Put your file name inside double quotes & use full path of Excel exe in Start Process activity.

I was also encountering the same issue & it got solved by above method.


Hi @Rohit,
I just forgot slash \ :sweat_smile::expressionless:

Hi Sajuri/Rohit,
am also getting same error while trying to open PDF file by keeping the full path in a variable. Please provide me some insight on this.


1 Like

I wanted to open a html file in edge browser, but my default browser is internet explorer. and I want to use only start process activity, not Open browser activity.
I tried giving the edge executable file location in arguments but still its opening in internet explorer. Can you help on this by referring the below image.