Specific Data schema definition is not valid JSON error

When uploading a JSON object as a specific data JSON schema to a queue if you include an “id” key you get an error saying the data schema does not contain valid JSON. Aside from this being a deceptive error message, it would be great id the developer had the freedom to add an id field to the specific content. While there is a Unique Reference attribute on every queue item I can see a use case where one would want everything to be contained in the specific data schema.

image

Hi @zspilman

Could you provide a sample of your JSON scheme?

test.json (34 Bytes)

Sure.

I see. If you check the documentation, the JSON schema is different than the actual queue item:
https://docs.uipath.com/orchestrator/docs/about-queues-and-transaction

Here’s a sample one from the docs:

{
  "definitions": {},
  "$schema": "http://json-schema.org/draft-07/schema#",
  "$id": "http://example.com/root.json",
  "type": "object",
  "title": "The Root Schema",
  "additionalProperties": { "type": "string" },
  "required": [
    "stringTest",
    "intTest",
    "boolTest"
  ],
  "properties": {
    "stringTest": {
      "$id": "#/properties/stringTest",
      "type": "string",
      "title": "The Stringtest Schema",
      "default": "",
      "examples": [
        "stringTest"
      ],
      "pattern": "^(.*)$"
    },
    "intTest": {
      "$id": "#/properties/intTest",
      "type": "integer",
      "title": "The Inttest Schema",
      "default": 0,
      "examples": [
        30
      ]
    },
    "boolTest": {
      "$id": "#/properties/boolTest",
      "type": "boolean",
      "title": "The Booltest Schema",
      "default": false,
      "examples": [
        false
      ]
    }
  }
}

And here’s a sample use with the corresponding JSON input:
https://www.jsonschemavalidator.net/s/3Q04GV69

As you can see, you will simply have to edit the sample schema a bit to make it work.

In this context, the error message is quite on point - your JSON was not a JSON schema that adheres to the specific set of rules.

Hey so i just tried prepending the id tag with a dollar sign like you have in the example above and it worked. Not sure why this is a requirement but this is a workaround that can be used.

ps. the link you posted, results in a 404 for me .

Zev

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.