Source: Get IMAP Mail Messages Message: Invalid credentials (Failure) Exception Type: MailKit.Security.AuthenticationException RemoteException wrapping MailKit.Security.AuthenticationException: Invalid credentials (Failure)

Hi team ,
Can you please help me why am i getting this error again and again, eventhough i have set IMAP configuration, sever, port everything? Thanks in Advance!

Source: Get IMAP Mail Messages

Message: Invalid credentials (Failure)

Exception Type: MailKit.Security.AuthenticationException

RemoteException wrapping MailKit.Security.AuthenticationException: Invalid credentials (Failure)
at UiPath.Mail.Activities.GetMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

3 Likes

Hi
Welcome to uipath community
Kindly check with these pls
—Username and password of the user mentioned in the property panel of IMAP mail activity
—In ur gmail Accounts settings Turn on “Allow Secure apps” and try the workflow.
—also make sure that IMPA is enables

—and finally here you go on how to create app password in gmail for uipath

Cheers @rajranjan018

4 Likes

Adding to this, in Gmail you will need to create app password as well :slight_smile:

1 Like

In gmail you need to turn on the “Less secure app access”, this will allow UIPath to access gmail.
You can turn this on from the following: Google Account settings > Security > Less secure app access > on

3 Likes

Thanks a lot @Palaniyappan, I was stuck with the same issue.

1 Like

Cheers @syed1980
Happy new year :partying_face:

where we get this ( Less secure app access >)

Turn on “Less secure app access option”.-

You can turn this on from the following steps:
->Google Account setting
->click on Accounts and imports
->under change account settings- click “other google account setting”
-> Choose “Security” Tab
-> In right pane after scrolling down you can find the same option.

1 Like

hello,
I am getting same error while accessing outlook email. Could you please advice what changes needs to be done for outlook 365? thanks in advance.
Error:
Source: Get IMAP Mail Messages

Message: LOGIN failed.

Exception Type: MailKit.Security.AuthenticationException

RemoteException wrapping MailKit.Security.AuthenticationException: LOGIN failed. **
** at UiPath.Mail.Activities.GetMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)

** at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)**
** at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)**

@pgovardh - pls change the imap email property value - ex: from abcd@xyz.com to abcd
and try.

Thanks for the response. I tried without the domain part but still getting the same error. Attached the properties.

image

@pgovardh - try secure connection property to None.

i tried secured connection with None option, getting below error:
RemoteException wrapping MailKit.Net.Imap.ImapProtocolException: The IMAP server has unexpectedly disconnected.
at UiPath.Mail.Activities.GetMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

https://myaccount.google.com/lesssecureapps try updating google account setting

sir…after enable the secure app setting it still show invalid credential

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.