Credential error showing when running

all my settings of gmail is okay, still this error is showing .

A couple of scenarios that may cause this:

  • If you’re using gmail. You will need to enable “less secure apps” or generate an “application password” when 2factor authentication is enabled
  • If your server is not using SSL port should be 143
  • If your provider has 2factor authentication you may need to consult their documentation

Hi!, maybe you should check if gmail is blocking your access you can see this on security on your gmail account,

another possible solution is to enable less secure apps and also enable POP/IMAP on gmail settings

let me know if it was helpfull

Hi @ydash999,

Follow the links below. There are many solutions suggested.


1 Like

all settings are done, i changed port from 993 to 143 and it is showing 'timeout exception"

Please increase the timeout and retry.


not working bro

there is no option now in gmail to enable or disable less secure app. what to do bro

unable to see on/off option for less secure apps. its no more available in gmail i think as its not showing

is there any solution for that?


Did you try enabling less secure apps

hi. there is no on/off option to choose in less secure apps, i have already stated above

@ydash999 Can you check the pwd variable contains right password

yeah it has right password.i had to execute the process by turning on 2step auth and creating app password, as the less secure option has no option of on/off .

Try this

i am unable to access, unable to log in to google workspace(console) as it is not business mail id i think

Go to Manage Google Account → Security → Scroll down and there you will find an option of less secure apps → enable it

Hi @ydash999,

From the comments I see is gmail, so stick with 993

Are you using 2-step verification? If that’s the case you need to generate an application password

Sign in with App Passwords - Google Account Help

Otherwise, if there is no 2-step verification and you still don’t have the less secure apps. Work with your administrator who should be able to grant you the required permissions

1 Like

before i think 6 month, less secure option(yes/no) was available. i dont know why it is not now. yeah i turn out to use the other way i.e application password method. thankss all

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.