EmailAutomation getting error

Hi Everyone!..
While I’m performing on email automation with the excel file,…everything debugging fine. but end of the point smtp and imap both activities are getting error. I tried with solutions previously which already posted by some other people in our UiPath community. So please let me know solution as per Updated Gmail Settings. Your solution would be greatful to me…

with IMAP getting this error…

with SMTP getting this error…
image (1)

Hi @KuruvaJayaPrakash

Check out this threads

Hope it will helps


Thanks for the suggetion @Gokul001 but Gmail settings are updated. So that is why it is not showing less secure app access in my account. that is what I’m getting issue…

Hi @KuruvaJayaPrakash

Firstly, check whether IMAP option in your Gmail Settings is enabled or not and then follow the below steps.
(For Enabling IMAP - Open your Gmail account click Settings on top right corner - click See all Settings - click Forwarding and POP/IMAP tab - Enable IMAP)

Next, click on your Mail Profile - Manage your Gmail Account - Security - 2step Verification - scroll down then you can find App Password click on that - click Select app - Select Other from drop down and then type SMTP and click on Generate - Save this Pw and Use it in Send SMTP activity Properties - In password option.

Before proceeding with above steps, you have to enable the 2step verification.


mridul.badgurjarMridul Badgurjar



i read it but didnt get much of it . are there any new server and port settings to send mail to outlook accounts?


  1. Go to your mail setting Forwarding and POP/IMAP and enable the IMAP access:
  2. Click on your profile and click Manage your Google Account.
  3. Security and then click 2-Step Verification after entering the password of email
    4.Below you can see the App passwords and generate the password that password you need to give then it will work

Hiee @vinitha_yachamaneni …your solution has done my pending activity…Thank you …

1 Like


My pleasure Jaya Prakash :slightly_smiling_face:

Cheers ,
Happy Automation !

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.