[Solved] Downloading and Moving File (Couldn't read Variable and report error)

Hi there,

I have found some similar topics but could not find the answer, just wondering if anyone of you can help on this.

I have setup an automation to download an excel.xlsx file from a company website and move it to another folder immediately after download.

It runs alright just before Move File kicks in

1 out of 5 runs will report of moving file error with msg: could not find the .tmp file in where the Downloaded file is at.

Wait for Download - Downloaded file - already set it to variable

Move file From - Downloaded file variable + .FullName

I thought there was a delay issue, so I added 2 sec before Move File, but still received errors sometime.



Here are some screen cap

Screen cap 2


Can you try to set “tmp” in IgnoreFileExtensions property?


Just spot this option, let me try.


in the ignore these temporary file extensions field out “tmp”

also check inside the activity to download in your wait for download activity is the correct one, because looks like you are not using properly the activity. It should be some click activity


actually it is click activity, where UI will open Edge and search for the export button, then do a left click


it should be the last click activity, that one that will download the file, last of last


Can you try your logic inside retry scope so that whenever robot didn’t find any file then it will retry. Don’t give any condition

I have tried running 10+ times with different scenario, it is now working, thanks all.