SOAP Request & Yoda Talk API

I am working on a SOAP request API example and am stuck. I am trying to use the following

http://www.yodaspeak.co.uk/webservice/yodatalk.php/yodaTalk/?WSDL
image

If I pass the string above into SoapUI it works as expected and I can create a request based on the output it gives me. I just replace the ? with the sentence I want to use with the API.
image

<soapenv:Envelope xmlns:soapenv=“http://schemas.xmlsoap.org/soap/envelope/” xmlns:yod=“uri:http://www.yodaspeak.co.uk/webservice/yodatalk”>
soapenv:Header/
soapenv:Body
yod:yodaTalk
?
</yod:yodaTalk>
</soapenv:Body>
</soapenv:Envelope>

This is the output I get in SoapUI after passing you are my favorite person as the ? variable.

<SOAP-ENV:Envelope xmlns:SOAP-ENV=“http://schemas.xmlsoap.org/soap/envelope/” xmlns:xsd=“http://www.w3.org/2001/XMLSchema” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance” xmlns:SOAP-ENC=“http://schemas.xmlsoap.org/soap/encoding/”>
SOAP-ENV:Body
<ns1:yodaTalkResponse xmlns:ns1=“uri:http://www.yodaspeak.co.uk/webservice/yodatalk”>
My favorite person, you are. Herh herh herh.
</ns1:yodaTalkResponse>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

This should be the URL you have to use @LeftBrainCo

http://www.yodaspeak.co.uk/webservice/yodatalk.php?wsdl

Actually, if your wsdl URL is correct, then you will get the output in any browser as

But your URL is giving the error. Can you try and check? and even the SOAP UI tool URL is different from the one you are trying in UiPath.

Does this work @LeftBrainCo ?

Please let me know

1 Like

I still get an issue with the correct url. I think what I posted above was me just trying a few things to see if I could get around the error.

Here is the test I did just now.
image

The error states that the wsdl doesn’t contain the parameters to recognize the wsdl as xml w3c schema.

Github has a solution for that and they are providing a wsdl. https://github.com/brigand/twiddlekins/blob/master/Utility/yodatalk.wsdl

  1. Download the file and save it with xml extension.
  2. Instead of giving the url, browse the xml file you saved
  3. You will get the methods and classes available.

Let me know if it works :slight_smile:

1 Like

Thank you I did not realize I could use a saved wsdl like this! That being said it is still giving me an error. Did it work when you tried it? Still works in soap UI

It only excepts .wsdl files it will not let me pick it if it is an xml

Yes, it is working in soap UI, looks strange and when I tried to search the error , I found some thing like service reference is missing. Don’t know exactly what to do in UiPath, but when i run it in visual studio, it is still working for me.

Sorry @LeftBrainCo …Will let you know if I find anything

1 Like

I noticed it shows the error below when using the file. It looks like it is trying to use the prefix tns:http instead of just the tns. tns is defined but for some reason it is taking the http as part of the defined element. Not sure why that would be though, as that is a bit above my knowledge base.