Slow Step Required

Hello,

I’m totally new to this and i’m creating my first flow by using web record.
the process i am trying to do is really simple : type a url to go to a site and login.

The problem : When I run my activity, the url is being typed missing few letters as if it was being typed too fast, so eventually i get an error of site not found. However, when i tried running using the slow step, it worked just fine.

Is it normal?

here’s a screenshot for the record :

image

the problem is happening with typing the url in “type into edit” activity.

1 Like

Hi
welcome to uipath community
in TYPE INTO activity set DELAYBETWEENKEYS property with some timestamp around 2000 milliseconds and try once

Cheers @YaraZakaria

use open Browser activity,

browser

Give your url directly in properties.

Thanks!

1 Like

@YaraZakaria

Use Type Into activity and indicate that element you want to type text. And also check some options like ClickBeforeTyping, Empty Field for that activity and then try once.

Check the EmptyField checkbox in type into activity.

Thanks!

Fine
–if we want to open a browser with a url then use OPEN BROWSER activity and pass the url as string input
–then to type into any field within that browser use TYPE INTO activity with these properties enabled
simulate type
emptyfield
clickbeforetyping
Delaybetweenkeys with 2000 milliseconds
waitforready set as complete

Cheers @YaraZakaria

Thank you for your replies.

I have checked what you said but it is still not working…

I keep getting this error
*> RemoteException wrapping UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: —> RemoteException wrapping System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector: *
> at UiPath.UiNodeClass.FindFirst(UiFindScope scope,
> String nodeID)
> at UiPath.Core.UiElement.FindFirst(FindScope scope,
> Selector selector,
> IPlaceholderResolver placeholderResolver)
> — End of inner exception stack trace —
> at UiPath.Core.Activities.TaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context,
> IAsyncResult result)
> at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context,
> IAsyncResult result)
> at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor,
> BookmarkManager bookmarkManager)

I even tried to record using chrome browser with the info already appearing in the record but i still have the same error.
this is my selector
image

Hi @YaraZakaria,

Hope you are doing well.
This site of Chronos has very limited Selectors available thus it can be challenging.
What you are doing is correct though please use Ui Explorer to find more element to build strong Selectors. what you need to do is:

  1. use Open Browser activity and send Chronos link to it.
  2. In Do section of Open Browser, use 2 Type into activities for User name and Password only, you do not have to use Click activity (if you are still using it)
  3. User UiExplore to explore more elements of the Selectors.

If you are still facing the error, please share your xaml file to check.

PS: I am from Orange as well so I will be able to check. :stuck_out_tongue:

regards,
Mayank

@mayank_26 Hello Thank you for your response.

It was working fine on IE but my target was to make it work independently from the browser used because I found it a bit limited if it only works on IE.

I fixed it finally by adding name='usr' in the selector and removing app='chrome.exe' . Now it works in chrome and IE.

Even though the solution was simple, i would say that it wasn’t trivial at all to find it because even when i tried with UiExplore I got too much info (like class name and parent id, etc…) and they were not efficient to find the element.

Do you have any tricks or hints I would use for later problems? I already saw the tutorial videos and some of the guides point but when it comes to applying them… it is quite challenging :sweat_smile:

Thank you anyway!

Regards

Hi @YaraZakaria,

That was actually the solution, there is no shortcut to it. you need to use correct elements in the selectors to be able to get it used in correct Browser.

Chorme and Firefox are not the official Browsers in most of the MSCs and thus IE is the best to use.

regards,
Mayank

Did you try changing app=’*’?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.