Simulate Click breaking subsequent clicks

Trying to automate a program and I’m noticing an error. Simulate click appears to click however the actions after the first click do not work, and do not throw an error even after 30 seconds. Testing the clicks on their own appears to work. Canceling out of the dialog box and bringing it up manually appears to work. I’d imagine most simulate click errors would occur on the activity they are affecting not down the line. I’ve tried with simulate click on/off on the subsequent activities as well.

Hi @Joshua_Khoo,

It can happen that some elements in the application don’t support Simalate clicks. You can try SendWindowMessage click or Default click instead.

Hi @Joshua_Khoo

Have you tried to use Check activity to operate radio box?
I think it will work better than simulate click.

@cmolina I’ve tried both. But the activity itself will run with simulate click it’s just subsequent ones are affected by whether or not simulate click is used.
@wusiyangjia Yes, and I had the same issue.

Hi @Joshua_Khoo

Another two methods, use Set Focus activity to check the radio box,
or use Send Hotkey activity to send “enter” to the radio box by SendWindowMessage.