Setting up VMware Horizon

Hi all,

Im currently helping a client set up UiPath to operate on a thin client running thorugh VMware Horizon Client. Its not working. Im getting following error message when I try to make selectors:
image
I have gone through the documentation pages a couple of times and following the guides there and have done the following:

  1. Installed UiPathRemoteRuntime on the application server (and verified that it is running)
  2. Installed UiPathRemoteRuntime and UiPath VMware Horizon-extension on the terminal server in between the client machine and the application server.
  3. Bypassed the terminal server and tried running directly on the application server.
  4. Installed the VMware Horizon-extension on the client machine.

Still the same error.

I can read in the documentation for the Citrix-extension, that Allowlists needs to be updated to allow UiPath Virtual Channel in order for it to work, but is this applicable to VMware Horizon as well?

I cant find anything on the forum about this topic and would be really interested in hearing if anybody have experience with setting up VMware Horizon.

Best Regards
Mikkel

Hi @RobotMikkel

Could you check if the Launch task was create successfully in Task Scheduler and if it was set for any user?

1 Like

I have and it is running.

Citrix and VMWare Horizon are two different things.

There is nothing mentioned in the documentation about a terminal server between the client and app.

1 Like

First off regarding the documentation you’re absolutely right, it’s not mentioned there. I describe it because it is the actual setup the clients programme is running and the robot is supposed to use. I found it in the UiPathRemoteRuntime (at the bottom). Here the setup via Terminal Server is described. But it didnt work either and as I stated in my post we have also tried bypassing the terminal server to no avail.

Secondly I agree that Citrix and VMware are different things :smiley: But UiPath on VMware also uses Virtual Channels to communicate back and forth. I have found VMware guides to setting up allowlists, but the winreg steps and folders they describe are not present on our client machine or the application server. If anybody have actual experience with getting VMware Horizon setup working I would love the hear the details :smiley:

Best regards
Mikkel

1 Like