Session has been idle over its time limit

RDP session shows pop-up with message "Session has been idle over its time limit. It will be disconnected in 2 minutes." It shops the unattended automation.

Pop-up message :


with a log in event viewer as :



This message pops-up when robot performs back-ground operations and it looks like an idle session to the OS. 
Please note this pop-up comes up because of session settings on the machine and not related to UiPath.  Request you to get in touch with your IT team since they will be the best team to have an idea about what needs to be configured in place.

Below are the 2 settings we noticed which are responsible for having an idle time :  
1. MaxIdleTime key set in registry : 
Please go to registry "HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows NT\Terminal Services\" and look for MaxIdleTime. You can set it as per your requirements or also set the value to "0", which equates to "Never".



2: Keep-alive connection interval in Local Group Policy :

  • Open Local Group Policy Editor 
  • Under Local Computer Policy navigate to Administrative TemplatesWindows Components > Remote Desktop Services > Remote Desktop Session Host > Connections and change the settings under Configure keep-alive connection interval.
  • For an even finer adjustment you might also want to look under Session Time Limits and change the settings under Set time limit for disconnected sessions.
  • In the right panel, double-click the policySet time limit for active but idle Remote Desktop Services sessions: in the modal window that will appear, activate it by switching the radio button from to Not configured Enabled, then set the desired amount of time in the drop-down list right below.


Version: any