Session has been idle over its time limit. It will be disconnected in 2 minutes - Troubleshoot steps

Description

Session has been idle over its time limit. It will be disconnected in 2 minutes.

Troubleshooting steps

Please implement the below approach (below are the findings from a few cases which helped to solve Idle time issue )

Approach 1: - Approach Confirmed

One of the known cases, the issue was resolved after removing registry setting for MaxIdleTimeout from DC (Domain Controller) level for the group policy .

Registry Hive: HKEY_LOCAL_MACHINE
Registry Path: \Software\Policies\Microsoft\Windows NT\Terminal Services\


You can also set the value to “0”, which equates to “Never”. Try out both the ways

Approach 2:

Open Local Group Policy Editor

under Local Computer Policy navigate to Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections and change the settings under Configure keep-alive connection interval .

For an even finer adjustment you might also want to look under Session Time Limits and change the settings under Set time limit for disconnected sessions .

In the right panel, double-click the policy Set time limit for active but idle Remote Desktop Services sessions : in the modal window that will appear, activate it by switching the radio button from to Not configured Enabled , then set the desired amount of time in the drop-down list right below.


Note: Request you to get in touch with your IT team since they will be the best team to have an idea about what needs to be configured in place.

3 Likes