Send smtp mail not working

Hi All,

When I try to send a gmail message using SMTP .I am getting an error message stating “No such host is known”. I am confused how to use that . Shall I need to configure my gmail in outlook inorder to send and receive mails. I am getting the same error when I try with Imap and POP3 for retrieving mails.
anyone please help me with this.

have you checked the host port and server ?

Hello @DevendraTummala

Please check following setting.

SMTP server address: smtp.gmail.com
SMTP username: Your Gmail address (e.g. example@gmail.com)
SMTP password: Your Gmail password
SMTP port (TLS): 587
SMTP port (SSL): 465
SMTP TLS/SSL required: yes

Please Feel free to contact me if you still facing issue

Best regards,
Aditya

Hi @rahatadi . Thanks for your reply.

I have worked the same way but I am unable to connect to gmail

Hi @DevendraTummala,

If you are using it with Gmail account you need to grant permission “send mail with less secure aap”

Mail.xaml (6.0 KB) refer this workflow. it is working fine for me.

Cheers :slight_smile:

1 Like

hi guys…I’m getting this error …any idea?

image

before was working fine …but now I guess that is because the new version …

here I found the solution … Send SMTP mail message gets an invalid certificate error after updating to Mail activity 1.1.6562.21018

Thanks for the solution. it worked.

Hi @Adityan @Aditya1,

i am using Smtp Mail control to send a mail

in Secure connection :there are several options are: Auto, None, SsIOnconnect, StarTIs, StarTIswhen Available 5 options which one i need to use ?

then SSL and TLS you are saying in properties not available

in port : we need to give this no 587 or 465

Hi, below is my error
could you please help me out

"Main has thrown an exception

Message: The requested name is valid, but no data of the requested type was found

Source: Send SMTP Mail Message

Exception Type: SocketException

System.Net.Sockets.SocketException (0x80004005): The requested name is valid, but no data of the requested type was found
at UiPath.Mail.Activities.SendMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)"

Go to Setting of gmal from you ae sending emal ,securtty section,allow less secure app option ON by default it is off

  1. List item

Have you got Solution ?

Use “Secure Connection” As None

error
anyone know what error is this

2 Likes

Hi @Nanyang_Polytechnic

If it is about gmail, see this post:

Also, check out our Google activity pack on Go! :slight_smile:

HI @Nanyang_Polytechnic did you solve this SMTP issue. If it is solved please update me how to solve.

Regards,
@robby.ram

Can you check this post if you are using gmail: SMTP Activity Error

check the port number and check the server details

i had the same issue i just turned off my anti virus

:slight_smile: hope it helps

1 Like

I have same issue can anyone help what i am doing wrong ?