Send SMTP mail Message activity(v 1.10.4) not working?

The SMTP mail Message activity included in the Uipath.Mail.Activities = 1.10.4 is not working. It throws following error


If the package is downgraded to v1.9.5 the activity works fine.

This error message shows that the problem is with hostname, but in previous versions, with the same hostname the activity was working fine. Also in the new package version the IMAP activity works absolutely fine with the same hostname.

What could be the possible reason?

Hi @kumar.varun2

Check the remarks paragraph SslHandshakeException Class

But it is working for the v1.9.5 with the same properties.

Also the IMAP activity for the v1.10.4 works fine.

UiPath enhanced the security level in 1.10.4.
If you want to use the above package you need to change the property of SecureConnection to None.

Already tried, not working

@uipath is this a bug?

@ovidiuponoran could you help

Hi @kumar.varun2
I’ve tested the activity from version 1.10.4 with parameters Server = “” & Port = 587 & SecureConnection = Auto & User = “…”. It worked fine for me.

But I’ve seen this issue happened to others as well, so I would like to make a call together to show me how it behaves at your side. I will write you a private message.

Hi @kumar.varun2

If possible, I would like to schedule a call with you this week to have a look at your environment, as we cannot reproduce the behavior. Would that be fine with you?

@kumar.varun2 Can you please try with all available options for “SecureConnection” parameter and let me know if it works for one of them?

This error tells you what the problem is. You’re probably using a DNS name (ie and that DNS name isn’t referenced in the certificate. Have your security team fix the certificate.

But IMAP works fine with the same server name

I have already tried that. Nothing works

The mail server is probably using different certs for SMTP vs IMAP. The error message is clear. Listen to it.

how can I view the DNS in the certificate on my system. Is there any way?

You’d need whoever manages your email server security/certificates to deal with it.

Could it be possible that this error occurs because the server certificate is signed using SHA-1 algorithm?

Can we provide ip address in host server properties. If yes then in which format?

@postwick @ovidiuponoran

What could be the possible reason for this? (I tried by changing the host server. In all the cases I have used port 25)


On changing SecureConnection to None


Also when I Telnet using the server IP and port 25, the telnet works fine.