Mail Activity Version Issues

Hi Everyone!

I’ve been having a known issue with UiPath.Mail.Activities.
The activity will only work on version 1.1.6361.22988.

If I change versions at all I get the error: No compatible authentication mechanisms found. Using the UiPath.Mail.SMTP.Activites.SendMail activity.

For a while using the only version that worked was a fine solution, but now I cannot find that version in the pack manager for Uipath.Mail.Activities. So all of my new projects will have to find a better solution.

I know the port number, server, and logon information is correct.

Is there anyway I can fix this issue or find the older version of the activity that works for me?

I have the same issue.

My Resolution: On the Send SMTP Email Activity set the property “SecureConnection” to “None”

2 Likes

@zwils0 - we have to do the same thing at my company for all versions > UiPath.Mail.Activities.1.1.6479.13205

The error is due to the configuration on our SMTP server. Rather than getting that fixed, we just set the SecureConnection property to none as well

1 Like

Even when I switch SecureConnection to None, I get the same error :frowning:

Thought 1:
Do you know or have any way to find out if your SMTP server uses SSL or TLS? Depending on way it is configured you could try the other Secure Connection Types.

Trial and Error may be the fastest.

Thought 2:
If you are using Office 365? If so you could use the Send Exchange Email Message instead,

I’ve tried all the other connection types as well, all have different error types that bounce back. But none work

I just noticed you mentioned:

know the port number, server, and logon information is correct.

I know in some of the places I worked their SMTP servers don’t have logon information.
Have you tried removing the logon information and setting the security to none?

Still “No compatible authentication mechanisms found.” With no logon or password strings

Thank you for trying to help!