Send HotKeys - Space


#1

James, Andrew
May 17, 2016 18:01 ANSWERED
Hi,

I don’t see an option to use the special key ‘space’ within the send hotkey activity. Would it be possible to get this added? I have tried manually typing space and selecting the check box for special key but this throws an error message. Reason for use is Shift + Space in excel highlights the row(s)

Thanks


#2

Andrzej.Kniola May 17, 2016 18:13
It works fine without SpecialCharacters checkbox (normal space is treated like a normal printable character), also with ctrl+space.

Just make sure you’re not editing the cell, as SendHotkey might send the key inside the cell instead of as a hotkey to the application.


#3

Mihai Badita May 18, 2016 17:19
So, just add a normal space in the Key property.


#4

Is it possible to send three key strokes to a window
Alt
space
X

this would allow us to maximise a window with keystrokes. Is there any way we can maximise windows with keystrokes ?

(I guess we need to send the third key stroke to the submenu - yes ?)


#5

Is this citrix automation? if not try using maximize activity for that. also try to use typeinto if it’s a citrix automation.


#6

And browser?. I’m trying but UiPath says me that “browser” is not “window”.


#7

Suppose, if you are using citrix automation or if you have to try using hot keys to maximize window,
You can do alt space X in 2 hotkeys activities


#8

Oh, that’s right. Thanks man. I can see clearly now :wink:

PS: By the way, also works out of citrix!


#9

hi Team, i have been trying to use this send key option for Ctrl+P to enable print option on google chrome. Unfortunately UiPath is not recognizing. I tried many ways and finally posting my request for help.


#10

Hi rkelchuri,

As far as I know there’re 3 possibilities;
-Chrome extension is not installed
-Selector isn’t set properly
-“SpecialKey” option is checked (This might happen when you first chose any special key from the dropdown and then changed it into a normal key. The checkbox won’t be unchecked automatically.)

I’m really new to UiPath but I was able to send Ctrl +p to Chrome and it shows me the print page.
*by the way, selector is as follows


Anyway it’ll help certified members to investigate your issue if you put more information, such as Properties for “Send hotkey” activity and error messages you encounter.


#11

hi Taniya, Thanks for quick reply. Yes i have enabled my chrome extension, modified proper Selector which is detecting browser and highlighting. verified SpecialKey option which is un checked. Still not able to use send keys for Ctrl+P.
I think i am missing something… i am always getting “Desktop had been disconnected while performing UI action” message.


#12

That’s another story. Please search.


#13

hi Badita, Thank you for your inputs… you are correct… “Desktop had been disconnected” … message is different.
I made some more research and finally i found the solution. When we enter Ctrl+P we suppose to pass as Ctrl + “P”. The letter “P” must enter in quotes.


#14

This worked for me, with Hot Key -> selecting Alt and using " x" (space + x) as Key


#15

Thanks it did work for me


#16


Just follow my given image.In first send hotkey activity in Key type " ", in my image that is a cursor.
I hope it helped you


#17


Follow this image, I hope it helped.