Send Hotkey or Click activity is not working for save as the excel file on Data Access Studio application

Hi Everyone,

I tried to save as an Excel file on one path in the Data Access Studio application, But nothing worked when I ran the process. but it is working when I click manually.

Please find the snap:

Could you please guide me.



When you save As, Are you clicking on the save button or firing Hot keys to do it?

Can you specify where you are trying to click.


Hi @prateek.mehandiratta9,

I tried to click the button. please find the snap:

I tried to send the F12 hotkey.


Can you try the save button before it.

I think so send hot key working but file takes time to save. are you closing immediately after save?

Bot has successfully clicked the Save as button, but the window is not opening.
When I tried the save button, I also got the same issue.

Change the click to hardware type or Simulate, see if that works

Hi @raja.arslankhan raja.arsla,

I don’t want to save the file. I need to click the save as button and type the file path to save in particular folder.

I gave 2 minutes after clicking the save as button or sending the send hotkey.

When I used simulate, it was throwing exception like simulate does not support.

@sandhya.govindharam Which keys you are using to save as?

How about Send Window Messages:


I was used F12 keys

1 Like

OK I will try and let you know

@sandhya.govindharam Its Excel File?

Did you try with “fn”+F12

it is not working.


That Excel file is opening in one application (Data Access Studio (Mainframe)). We need to save that file.

Try to close the excel, see if its asking you to Save first, you might be able to spy that save Yes/No popup.



Try using anyone of UI framework sure click activity will work

Hope it will help you


If you want to work with hot key use start process open those Excel one by one then usee attach window within that u better try to use hot keys it will work don’t run in debug mode run in run file mode

Hope it will help you