Selector sometimes working sometimes giving the following error

i am using modern activities, and getting this error, on several selectors


use an attachs browser activity to ensure the correct search of the selector


all selectors, are being used on 1 single web page, then why will i use attach browser activity,
i am already using Application/browser activity

the error tell us that the element was not found, maybe you can add some delays beetween the changes in the page? did you try in debug mode if its finding correctly the selector?

did you tick “enforce element visibility” when indicating the element?

Hello @Mystical_Devices ,

Please try to debug the issue using Step Into feature in the Dubug Tab. Move to each step and understand where the issue is happening. If the element is taking more time to load, plzz use Delay or WAIT CONDITIONS. If still failing need to check the selector of the Element and recomending to use Anchor base.

where can i find that option?


This did not help
i even used Hover activity, to lock onto the element, so that the selector can select it,
and still gives error

he is on modern. You don’t use Attach Browser in modern.

The error tells us the window that was originally attached to no longer exists.

This error indicates that the primary element (ie browser window, application window, UI Element etc) no longer exists. Check to see if something is crashing. Can you post screenshots of what you’re trying to click?

i am trying to press the .com button on the website ""


this si what i am trying to press,

sometimes it works, sometimes it gives the above error- thats what is bugging me,

you mean hover is successful (you can see it hovering over the button) but the subsequent click activity fails?

what selectors are you using? (selector / fuzzy selector / image) or did you tick all of them?

can you try this configuration?
<webctrl aaname='.com' parentid='currentLanguage' tag='SPAN' />

i already did that! no use, sometimes work, sometimes, says cannot find element

@Mystical_Devices Can you share your selector

Also, compare the selectors for successful run and failure run. Check what is changing

That is a different error than the one you originally posted. I just tried browsing to and it looks like it takes a long time to load. Are you making sure to wait for a known element to appear, which tells you the page has loaded, before trying to click?

this time i have done this:

verify execution activity i used-
but its still not working,

why does it work sometimes, and sometimes give “could not find element error”

i have also done this:

Still not working