Selector in Type Into Activity

Hi everyone!!!

In my project I am unable to insert data into a form field through the Type Into Activity because every time the page loads the field element is modified.

How can I proceed to resolve this?

Thanks

Hi
We got two options to handle this
Either the selector should be made in such a way that it should take dynamic attribute values by replacing those attribute values with wildcards *
To find which one is dynamic choose the element once and get the selector
Close the application and again open and select the element. Compare the selector so that we will be able to find difference
Replace that Attribute value with wildcard symbol *

Or

We can use SEND HOT KEY activity with key as tab to navigate across fields and use n number of send hot key with key as tab until we reach the field we want
Once after reaching use type into activity without choosing any element just mention the input string
So that it will type there
Then use a send hot key activity with key as enter

Cheers @Also_Pizzaria

@Also_Pizzaria

You can use Anchor Base activity to automate this kind of things. On left hand side use Find Element to identify that field in the form and on right hand side use Type Into activity to type the value.

Hi @Palaniyappan, @lakshman

Tried, but to no avail.

In addition to your suggestions I tried other ways, but nothing finds that element.

Could it be problems on my computer?

thanks!

hi also,

can you share the selector, which is before the load and after load, so that might be we can find some way to find

Thanks

1 Like

@ksrinu070184, Yes perfectly!

This is from the homepage. It’s working:

This is when the element appears again on the page after a product has been inserted.

This is the third time the element has appeared after insertion of the second product.

Thanks

Hi
Either remove the idx attribute by unchecking that attribute in the left side of this selector editor window
Or replace the value of idx with wild cards *

And also ensure that simulate type property in the property panel of type into activity is enabled

Cheers @Also_Pizzaria

Perfect…

@Also_Pizzaria, Check that Idx is keep on changing, so as palaniyappan said, remove idx and you can try

or

you can use a counter and increment the counter by how many times you are loading the page, you will get the idx value

Thanks

@ksrinu070184, @Palaniyappan,
Hi everyone!

First, thank you so much for your help and patience!

I can’t delete idx. It is the only data that changes in the selector. Even me clicking to uncheck it the system does not respond.
So I put opted to put the symbol * in place and the selector validated.

I also enabled Simulate Type in the activity properties.

Even so, the element is not found from the second loop.

A note: There is no error in the process. What happens is that the activity is being ignored. That is, the system “skips” the TYPE INTO ACTIVITY part.

Thanks again for your attention!