Selector Error While Recording

Hello all,

I am just following UIPath academy tutorial on the topic of recording with Notepad. I have made the recording but i Keep gettin the following error below. This particular error comes on the activity when I am selecting the font. The activity is called: Click 'menu item Font…'
How should i know what to change in the selector or what’s missing?

Error:

Click ‘menu item Font…’: Cannot find the UI element corresponding to this selector: wnd app=‘notepad.exe’ cls=’#32768
ctrl name=‘Format’ role=‘popup menu’ /
ctrl automationid=‘33’

image

whatever you are automating that should be opened first time while selecting Ui element. First click on format, select the font, change the font etc. If you want to learn about How to work with selector. Watch these videos.
UiPath Selectors: https://www.youtube.com/playlist?list=PL41Y-9S9wmyJDvFI2_cJu8LB3FmJSqO9k

Hello @Manish_Pandey
Thanks for your answer. I’m still not quite getting what exactly you’re trying to tell me.
I pressed F2 so there could be a delay in the recording so that I could go to the notepad toolbar and click on Format -> Font. However, I still got an error. I watched the selector video.

nolongervalid

If you want to open font dialog box and you can use Ctrl+Shift+F shortcut key using Send hotkey activity.

hello @alejohnson
When you are running the workflow is the notepad open ?

This error occurs when an activity does not get that particular selector to perform its task.
If the notepad is open then try to reindicate that particular element by clicking on indicate element and selecting that same element again

hello @vickydas

yes notepad is already open. I did exactly as the tutorial said. The funny thing is when I downloaded the the solutions, it gave the same error. I am in the RPA developer training -> Level 1 Foundation Training - 2018.3 -> Lesson 4

UiPath