Click is not firing on a button on Windows Application

I’ve created a sequence where I open an windows application and I click one of the button on the screen thru Click Activity. During execution I see the execution successfully steps out of Click event
without throwing any Selector error, However Click event seems to be not happening and I dont see any response on User Interface.

I tried to debug further by break it down with “FindElement” activity and Click activity. Find Element
successfully returns an UIElement that I can see it in local window and still the Click is not working.

What could be the issue?

The button I’m trying to click thru Click Activity is as shown here and the selector is given below.

@VenkatM The selector you have put is not displayed here.

1 Like


Screenshot of selector + button I’m trying to click is posted as reply below

Is the SimulateClick or SendWindowMessages property ticked in the click activity?
Some desktop apps do not support these methods

Whether you checked with the click image activity?
Avoid using the “idx” in the selector.

1 Like

image
tried that and getting this error. I tried to choose single option alone and it did not work

You can use only one option at once.