Click activity -> Could not find the UI element corresponding to this selector:

Hi, Maybe someone can clarify this problem for me…


The very first click is working just fine… after the first while loop I’m getting the next error… any idea…?

-I have tried to add actors → (still error)
-I have tried to use click activity for that specific position select region) → still error

  • I have used “click text” activity… ->still error


You can experiment with “SendWindowMessages” and “SimulateClick” in properties by setting one of them “True”.
Adding some delay using the “Delay Before” property can help too.

If you still cannot solve it, please upload a print screen of the whole “While loop” for context.

Thank you.

Hi, I have done what you told me… but unfortunately …the error is still present.

Hello @bradalfred,

Do you absolutely need to use a Click activity?
It seems that the button you’re trying to press has a keyboard shortcut that can activate it, so you could use the Send Hotkey activity. This one does not require such a precise selector. :slight_smile:

Just a thought.

1 Like