Selecting a value from a web drop down list

uiautomation
studio

#1

Hi Experts,
Trying to come up to speed on uipath with a real life example. I’ve been thru numerous tutorial videos, board postings, etc. and have made some great progress. However, I’m stuck on how to select a value from a web drop down list. I’ve already been thru countless postings on the topic and tried this about 100 different ways all with no success. Can someone help please? I have recorded my sequence numerous times as well but am still not getting anywhere. A pic is attached with detail.


#2

Hi @jlhoff350

Could you give it a try with the selector that doesn’t have the selectedvalue=‘0’?


#3

Hi @loginerror

Thanks for the suggestion. I tried a recording in a different app/site and the playback works perfectly yet my original problem still exists. My original problem existed before I tried to put in the selectedvalue=‘0’. It didn’t even work in my original example from the point of the initial playback.
Here’s a pic of the new test. The only difference I see is that in my original problem scenario there’s already a selectedvalue set in the program by default.


#4

Could you post a screenshot of the output from UI Explorer for that drop-down selection?
I had lots of luck using its aaname property in my selectors when other attributes did not do the trick.


#5

Yes, here it is.


#6

I also just realized that the values in colName do not match the values in the DDL that I selected. The values in the DDL I selected are yes/no.


#7

I tried a number of additional things and still no luck. I re-recorded the sequence multiple times so not sure how I’m getting the wrong values in colName either.


#8

It seems like an issue with the accurate selector.

Could you add an additional line to the selector above the current one:
<html title="*" />
where asterisk is the title of your page?

It might help.


#9

Awesome, that worked. I also had to do the same thing with the button on that screen to get it to work as well. The suggestions are highly appreciated!

Can you explain to me why that worked? Not sure I understand the reason behind it.


#10

@jlhoff350

Not sure why, but I think UiPath takes the selector of the window first and then a more specific one afterwards.
At least that was my thought process when I was debugging similar issue. It’s not obvious, but seems intuitive that we would have to provide more broad selector first for the window.

Don’t hesitate to mark the question as answered so that people in similar trouble will get quicker to the solution :slight_smile: