Select item in PowerBuilder drop down datawindow


We have a PowerBuilder application that we are looking at creating some automations for and need to select an item from a drop down list (drop down datawindow in PB speak).

I have tried to use the ‘Select Item’ action but when I click on the ‘Indicate on Screen’ link in the UiPath Studio and click on the sections of the dropdown marked 1 or 3 in the following screenshot I get an error message: “This control does not support select item”.

When I click on the ‘Indicate on Screen’ link in the UiPath Studio and click on the section of the dropdown marked 2 in the following screenshot it seems to pick up the drop down but when I then run the workflow (after setting the text of the item that I want to select in the dropdown) it either doesn’t select anything or gives the following error:

SelectDropdownItem has thrown an exception

Source: Select item ‘list item’

Message: Attribute not supported by the current UiNode.

Exception Type: ElementOperationException

UiPath.Core.ElementOperationException: Attribute not supported by the current UiNode. —> System.Runtime.InteropServices.COMException: Attribute not supported by the current UiNode.
at UiPath.UiNodeClass.Set(String bstrAttr, Object vValue)
at UiPath.Core.UiElement.Set(String attribute, Object value)
— End of inner exception stack trace —
at System.Activities.Statements.Throw.Execute(CodeActivityContext context)
at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)


Does anyone have any idea on what we might be doing wrong?

Thanks and Regards
Scott B

1 Like

Hi Scott,

we’ve been looking at automation around a PowerBuilder application and come across the same issue too. The only solution we have found so far is to select the control and then send hotkey with a single character (PowerBuilder only accepts one character, so you could have to send multiple hotkeys to select the correct dropdown option) - we also found two other quirks, we had to send hotkey with a tab after the character hotkey and if you try doing any of the above while recording the screen (or presenting on Skype/Teams) it didn’t work!

Did you find any solutions that worked for you?