Select Item Activity shows "blank"


I tried to use Select Item Activity to select the country in the drop down menu of a portal, but it fails and shows a blank field in the drop down menu as attached. However, actually there is no such blank choice in the menu.

Interesting thing is that the Select Item Activity works well on its own when I just try to test it again on a separate workflow, but it fails when it is used under another major workflow. I checked the Selector and all other properties are the same.



Hi @Snowman,

Try giving it inside Attach browser/Attach Window activity.


If select item activity won’t work then take two click activities one for clicking drop down box and other one is for selecting item from the list. And also make it dynamic selector.

Pass variable name into selector.

aaname = ’ “+variableName.Tostring+” ’

Thanks. I give the Attach Browser right before the Select Item activity, but it still doesn’t work.

Thanks. Are the 2 activities both Click activity ? The first Click can get the pull down menu, and for the 2nd Click, inside the Selector property, should I also copy the Selector from the 1st Click activity before appending the aaname= ’ “+variableName.Tostring+” ’ ?

It is a long list, and the choice could be in the far end of the list. Does it matter ?



Yes first one is for to click pull down menu and second one is for select any item from drop down list and in place of that item pass variable name into selector to make it dynamic.

It doesn’t matter how much big the list and it will select particular item from list immediately.

My first selector is: “”
and should my selector be: “”

With above, it can pull down the list, but then it said the UI element corresponding to this selector not found !

Am I wrong on the 2nd selector ?


Could you please paste your second click activity selector here.



Could you please show me the original selector by clicking one item from list.

In your selector name is variable of type String or not ? If not then write like name.Tostring

My name variable is of string type.

If I manually made a choice in the pull down manual, and use UI Explorer to indicate the field, it got the selector as attached (same as previous picture)
Since the pull down menu will roll back when any other key is pressed, I used F2 to pause and manually pull down the menu, but the UI Explorer return an error saying that The UiElement is no longer valid, as attached.


Yes you have to give some delay after performing first click activity.

HI @Snowman,

Check the selector & try

I gave 2 seconds delay, and still it doesn’t work. Wonder why the UI Elements of the pull down menu become invalid after the F2 pause.

After further trials over the last few weeks, I have some observations to share:

  • probably the Select Item Activity (when used in the sub-program of the main program) has not yet clicked on the selection as another windows pop up (that is why it shows “blank” on the data field) asking for confirmation of the selection
  • the Select Item Activity (when used alone for testing the function) works perfectly well. Not sure if it is due to processing delay or interruption by the pop-up windows when used under the main program !!
  • after investigation on the possible UI operations allowed by the portal, it is solved by using Click Activity (to click on the combo box), then using Type Into Activity to type the selection (has to be the default mode for “quick” input) follow with hotkey “enter”. The tricky part is to remove the selector of the Type Into Activity as it should not be typed into the combo box, but just anywhere in the browser.

Guess it may apply to many other different portals.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.