Scraping Data Table with No Selectors for Cells/Rows

Hey everyone!

I’m currently having an issue with scraping data from an application that doesn’t expose it’s selectors for rows and cells. I was wondering if anyone has experienced this before or has any insight on how to resolve the issue. Here’s the details explained as thoroughly as possible:

Situation: I want to extract data from a table using either Extract Data , Get Full Text , or Get Visible Text . Using the extracted data’s rows as a guide, I want to select the necessary checkbox using the Check activity.

Application: Encompass by Ellie Mae

Expected Result :

  1. Data scraping tool should allow me to select a cells or rows within the table to build Extract Data Activity.
  2. Get Full Text/Get Visible Text should allow me to select cell or row to get text.
  3. Check Activity should allow me to select checkbox element.

Actual Results :

  1. Data scraping tool: Cannot select cells/rows. Selecting element outlined in attached photos returns ‘This control does not support data extraction’.
  2. Cannot select cells/rows using Get Full/Visible Text . Selecting elements outlined in attached photos and running process returns empty value.
  3. Cannot select checkbox element with Check Activity. Once again, limited to the element outlined in photo 1 and 2. Returns Exception Message: “Attribute not supported by current UiNode”.

Troubleshooting Performed:

  • Tried spying element with Ui Explorer with no luck. The element’s children appear to only be the horizontal and vertical scrollbars. (All other grid’s children are not exposed).
  • Tried switching Ui Frameworks, once again with the same results from above.
  • Tried installing Java extension, no change.
  • Tried other tables in application and got the same issue.

Appreciate any opinions! Thanks.

Hi @Snels,

Can you try with Anchor base
Use find element
& click