Scheduling doesn't work in Orchestrator 2018.4.3

orchestrator
bug
#1

Scheduling doesn’t work in Orchestrator 2018.4.3. When I try to schedule any process the schedule doesn’t work, the jobs don’t even stay pending, it don’t appear! The job run manually!
can anybody help me?

1 Like

#2

@vornes - I am assuming that you are using an Orchestrator installed locally on your machine or in a network. Did you check the windows event viewer logs for any error?

1 Like

#3

I’m using orchestrator on a windows server 2016. Yes I have a lot of errors in the windows evet logs, most of these errors are of “Orchestrator.BusinessExcept” type

1 Like

#4

@vornes - My suggestion for narrowing down the problem is as below:

  1. Check if all the components are installed correctly without any issue as per the documentation.
    https://orchestrator.uipath.com/docs/prerequisites-for-installation
    https://orchestrator.uipath.com/docs/software-requirements
  2. If everything is installed properly, then please restart the IIS server and then check the logs after restart. Filter the logs for any UiPath Orchestrator related issues and resolve them.

If possible, please post the errors from the logs.

1 Like

#5

Can you check if database has quartz schema under UiPath database. If you have any environment where this is working then compare the number of tables between database and also try by using IIS reset

1 Like

#6

The problem was solved!

@sreenivasm yes, I checked and all the components were installed correctly, I restarted IIS and the problem persisted! So by discussing with our team of developers we come up with 3 scenarios: Firewall problems, License issues, Database problems.

@Akash_N_Jain the problem really was in the database! We made a copy of an existing database in another environment, then we installed the orchestrator on this already populated database, I believe that since the database was from an old version of the orchestrator it may have brought some conflicting component between the versions. Today I reinstalled the orchestrator using an empty database and everything worked perfectly!

Guys many thanks for the tips!

2 Likes

#7

@vornes - Glad to know your issue is resolved. And I have also learned in this process! :slight_smile:

2 Likes

#8

@sreenivasm yes, now we know that if you have a database of an orchestrator version 2016.2 and use in version 2018.4.3 will not work in the appropriate way

1 Like

#9

Glad to hear that.!

1 Like

#10

Another option is to have the key automatic database migration set to true in web config which will update scheme when you browse your website for first time.

3 Likes