SAP SuccessFactors Activities

Overview

SAP SuccessFactors is a world-leading provider of cloud human experience management (HXM) – the new people-focused term for HCM. Their HXM suite lets you provide employees with experiences that recognize their individual value and consistently motivate them to achieve peak performance levels.

The SuccessFactors activities enable you to automate interactions with your SuccessFactors application. Using the SuccessFactors oData API, this activities package gives your UiPath robot(s) the ability to execute functions and actions.

How does it connect?

This is where we need your help.

Before the scope activity can be used to establish a connection, you must complete the steps outlined in the Setup guide. After you complete the Setup steps, you can begin building your automation projects

Technical References

The Activities page includes a complete list of and the links to the SuccessFactors API operations used by each activity.

You don’t need to be familiar with the SuccessFactors API operations to use the activities; the references are for informational purposes only.

Get Started

Before you build your first project, complete the steps in the Setup guide.

To learn more about the SuccessFactors activities (including example property inputs/outputs), see the Activities page for a complete activity list and links to the activity detail pages.

6 Likes

Hi
we are exploring possibilities with these activities, however we dont seem to be able to connect using the Basic Auth option. As far as we know, the URL and credentials should be fine.

Is there something we should know regarding the Base URL?

Also, in the successfactors scope activity documentation mention OAuth Authentication, but havent been able to figure out where that option is within the activity?

This seems to be extremely interesting and would love to get this up and running.

Hi - do the basic auth credentials work when using something other than the robot, e.g. via direct URL or Postman? The base URL should be in the format of:

https://sandbox.api.sap.com/successfactors/odata/v2
https://apisalesdemo8.successfactors.com:443/odata/v2/

I’m guessing you are simply putting in the root and not the /odata/v2 aspect? If this is the case, then I’m thinking we can figure out a simple patch for that would not require the suffix, e.g. will append it automagically if missing.

Hi,
thanks for getting back at this. However the problem got solved by itself. I am not sure why, but when I tired the same settings few hours later the connection was successful.

Now I am facing another issue. I cannot access anything behind user/empInfo.

I am trying to search a record with userId as filter, in select and extend I have empInfo. I keep getting an error:

“error” : {
“code” : “COE_PROPERTY_NOT_INCLUDED”, “message” : {
“lang” : “en-US”, “value” : “[COE0022]Properties User/empInfo are not accessible. Please check the property name in Admin Center > OData API Data Dictionary or entity metadata.”
}
I have checked the OData API Data Dictionary and everything should be correct.
I was told that the query look fine at the successfactors end and it works using postman as well.

My use case would require to expand further to personNav, but the call already gets stuck at empInfo.

Select and expand works with other objects ie searching for team members in a managers team.

Any idea what could cause this?

Not at first blush. Could you please share the robot so we can take a look?

Hi

I cant share the configurations of the connection, but this should cover the details.

I am able to access values with the same setting as long as I dont try to access anything behind empInfo.

Does this help?

Yes, but I’ll have to get a dev to take a look I’m afraid. May be a day delay before they can respond.

@kumpujanne Thanks for reaching out. We will look into the issue and update you further on this thread as when there’s an update.

Thank you!
I keep investigating as well in the meantime, but as said. Everything looks to be ok, from API end.

This would be huge for us, as it would be a step further on way to allow us to do employee creation/update fully through these activities. I have managed to get few things working already and it seems to be tremendous improvement compared to UI automation.

If you would need more information, I might be able to share more details in private. Let me know contact details and I could reach out through company resources.

Another quick question. Are the other activities fully functioning already? I have troubles defining sys_id for updating a record. I dont know where that can be set.

Hello,

We have created a patch that lets you obtain data from expanded objects in the Search Records activity, which was your original request. Here is an example:

In the Achievement record there is a node called subjectUserIdNav which is a complex object

Currently if you wanted to obtain the city object you would set the Select and Expand properties as so:

This shows that you want to select the city in the subjectUserIdNav node of Achievement, and that you have to put the item also in Expand to expand out that object.

This was not supported in the current release (1.1.0) but is in the patch below. Can you please try out this update and let us know if it works for you as well?
UiPath.SuccessFactors.Activities.1.1.7688.14923.nupkg (1.3 MB)

There are some other ideas we have to make this even easier in the future (e.g. to navigate to these properties via the designer) but at least this will unblock you for now.

As for your second question, if you mean the sysid of the user, that is surfaced as userid at least if I understand you correctly:

Please let us know how the patch works, we’d love to get this released if all is good.

1 Like

Hi

thank you for investigating this. However, I still get the same error

image

Regarding my second question, I refered to the sys_id in the documentation(screenshot below).

If I were to update a record of a specific user, how do I define the user?
I tried setting the userId* value to userId and then update email Field, with new value. That did not work. Based on the documentation I started to think should I define the sys_id of the target user first somewhere.

Regards
JK

Thank you @Dhandapani_Murugan and @paul.hoeffer

My search records is working now! This was huge help for us!