Salesforce Connection Issue

Hi All,

I’m trying to connect my uipath with salesforce using salesforce lightning connector. Upon filling following parameters

UserName:
Password:
Security Token:
Consumer Key:
Consumer Secret:

I’m getting invalid client identifier error.

Can someone help me with this.

@Rammohan91
@Cristian_Negulescu

Thanks,
Ashok

Hello Ashok,
Please use the latest version from UiPath GO and for go configuration of salesforce server please watch this movies:


Also on the manual from UiPath go you have 30 pages manual and in the first page you have details how to configure the REST API.


Thanks,
Cristian Negulescu

Hi Cristian,

I used the latest one and did exactly the same as it is shown in the video. But still I’m getting this error.

image

Thanks,
Ashok

Hello Ashok,
Let’s do this step by step:

  1. In the Salesforce application Scope please that you have the correct selection I mean environment should be Design_and_Test and also the server should be TEST if you use Test.salesforce.com or LIVE if you use login.salesforce.com
  2. Check you the user and password on the web and see if they are working. IF yes go and generate another Security Token and wait 10 minutes and then tested with software.
  3. It is still not working please go to application manager and create a new app following all the steps from the movie. Get your Consumer Key and Consumer Secret and then after 10 minutes tested on UiPath.
  4. There is an option to connect without Security Token so you need to identify the public IP of your PC configure Salesforce to trust that IP and then in UiPath you will configure just User, Pass, ConsumerKey and Consumer Secret please leave empty the Token.
  5. Please use other free software to test the REST API connection and then after a positive result come back to UiPath Studio and check the connection.
    Thanks,
    Cristian Negulescu

Hi @Cristian_Negulescu, I am having the same problem. I went through all of your steps and it is still not working. I am able to access the salesforce api fine through some python code, so I know I can access it. Do you have any recommendations? Could I PM you some more details? Thanks

Hello Plato,
Do you have proxy connection ?
Be careful if you change the password your need to redo the Token you need to reset again.
Please do again APP definition on APP manager and be sure that you do exact steps from the movie with FULL Acces (full)


Please be sure that you use the latest version 725 from UiPath Go. If still not working give me some screenshots.
Thanks,
Cristian Negulescu

@Cristian_Negulescu. Thanks for the response. When I hit download it made me activate my license again (I have community edition - not sure if that matters), which I did, and then I looked for your salesforce packege and it wasn’t there. I had to go to manage packages in studio and the only one available to install is version 658, which I installed. This is what happened to me a few days ago, and it happened to me again just now. How do I get 725?

Please make an Account on UiPath GO and then try to download one of the packages:


After you download the NUPKG file on your download folder you add this folder in Studio on activities and you will see the version 725.

I actually do have an account already. I click download, the nupkg appears, I open it, uipath grinds a way for a bit, then I get a popup asking me to activate my license so I type in my email address, it says its successful, I open up a new process and the salesforce activity isn’t there, so I go to manage packages and install version 658 - the latest one available there. I’ve done this 3 times now and its the same each time. Not sure what to do.

Hi @plato,
CC:@Cristian_Negulescu

Could you please confirm if when trying to install the Salesforce pkg you were doing it from the Manage Packages section by selecting the pkg from your private feed or from the public one (Community)?
I just ran a test and I can see 1.0.0.725 version available in the public one.

Could you pls try one more time and let us know if you’re still experiencing issues?

Thanks much,

Alin

Thanks @AlinCopoiu, I now have version 725. Unfortunatley, I am still unable to connect. I will dm some screenshots to @Cristian_Negulescu

@Cristian_Negulescu looks like there is no dm feature. Anyway here is the page I get. I have followed your steps exactly as in the video and I have followed your documentation. I have tried it a few different times and always get the same error. My coworker tried to do it on a separate computer with a different account and got the same error. I know the salesforce api is working because I have accessed it from different places. Not sure what to do.

Ok the answer is very simple. Instead of username and password you need to put values not variables. The system accepts variables only on production authentication.

I had already tried using a variable or putting the values in. Neither worked. Just tried again and got the same error.

Hello Plato,
Add me on linkedin and will discuse more there we will change some code and files.
https://www.linkedin.com/in/cristian-negulescu/
Thanks,
Cristian Negulescu

Hello Plato,
You have here an application and the code to test your connection if you have C# experience you can understand exact also the code and modify.
Thanks,
Cristian NegulescuSFDCTestConnection.zip (2.5 MB)

I am having the same issue as Plato. Also, why is the Test button disabled for Production? It seems like you would want to be able to test if your connection to Production is good. Otherwise, you are just blindly trying settings.

As an FYI, I am able to get this to work in Stage (test.salesforce.com) but am getting the initial authentication error when trying to do this in Production (login.salesforce.com). Our setup uses IP so we don’t have to provide a token but I still get the initial authentication error whether I use a token or not.