RunAllTests.xaml Failing with ExcelApplicationScope Error!

The only change since last night was that I installed the Computer Vision Package into my UiPath CE Studio environment. The version is 2019.8.0 CE. I’m not sure what happened here. But here are the issues that I’m facing. Screenshots published below each of the items listed below :

All the REFramework Projects successfully deployed to Orchestrator are failing to deploy
There is only one error that is preventing the deployment:

If I Run the RunAllTests.xaml, it fails with this error:

If I remove the entire Excel Application Scope activity from RunAllTests.xaml, the error goes away.
When I add an brand new Excel Application Scope activity, the error comes back!

However, if I run the entire process on my local machine, it works without any issues!

In one environment, I noticed that some packages were marked for updates. I updated the packages and even this did not fix the issue!

What gives? :astonished:

I ejected the Test_Framework folder from the project and now I get no validation errors and I’m able to Publish Project to the Orch.

HI @AndyMenon

I’m having the same issue here…unable to publish because of this… I wonder what’s actually wrong. In my workflow, I have excel application scope for my excel sheeting updating things… they work fine, wonder what’s wrong with this specific one… :thinking:

1 Like

Hi again @AndyMenon

I think I figured it out…
Seems like they have made one property of the excel application scope mandatory when publishing. The output of the excel application scope

by default this doesn’t have a variable to hold whatever its returning. I added a variable there of Excel workbook application type and the validation error is resolved :smiley:

So you don’t need to exclude it from your solution :slight_smile:


Sweet! Thanks for figuring that out. I will run it on my end.

Regardless, I will have to leave it out.

Anything like %test%, %trial%, %free%’ etc will need to be removed during deployment.

Believe it or not, our CSO team scans our Integration Servers for the most secure version of Java and flag it if it isn’t.

That bugs me too. Why just this xaml?
Why not the others?
I think any new sequences with Excel App scope will break. Yesterday, I made a copy of RunAllTests and then completely removed the ExAppScope. Then, I pulled in a brand new one and gave it just the excel file path. When I validated it, the same error shows up.

I’m nervous about the existing ones breaking in the future if they make changes to their workflows.

Thank you for spotting the issue, our team will fix it :slight_smile: