Run uipath process from cmd line

Hi all,

I tried to run a process from cmd line.
C:\Users*\AppData\Local\Programs\UiPath\Studio\UiPathAssistant>UiPath.Assistant.exe -file "C:\Users*\Documents\UiPath\HelloCmd\HelloCmd.1.0.2.nupkg"

2023-09-21T04:24:48.966Z making sure files are closed…
2023-09-21T04:24:48.972Z all files are closed .

It tried to open the UiPath assisstant and in the cmd line "2023-09-21T04:24:48.966Z making sure files are closed…
2023-09-21T04:24:48.972Z all files are closed " i see these . Can someone please guide me how to run from cmd line and also please let me know why those files are closed .

1 Like


Try something like this

“C:\Program Files (x86)\UiPath\Studio\UiRobot.exe” -f “D:\Test\…nupkg file path ”

the filepath of the nupkg file needs to be mentioned something like this

This this thread recently opened and it worked
Have a view on it

Cheers @parvathi_ayanala


It is not assistant what you point to …but to uirobot.exe…please check this on different ways to execute

Also please note

Try highlighted


1 Like

im very new to this . so you are saying to cd C:\Users****\AppData\Local\Programs\UiPath\Studio\UiRobot.exe>

If i do this its throwing an error

1 Like

Instead of mentioning the file path UiPath assistant try to mention robot exe file path like this

“C:\Program Files (x86)\UiPath\Studio\UiRobot.exe” -f “C:\Users\…\Documents\UiPath\HelloCmd\HelloCmd.1.0.2.nupkg”

Note - mention your nupkg file path
I just mentioned with dots…

That is what is referred here too in UiPath document

Document for reference


1 Like

I will try and let you know. Thanks

1 Like

Hi @Palaniyappan and @Anil_G ,
Its working now .
cd C:\Users*\AppData\Local\Programs\UiPath\Studio>UiRobot.exe -file "C:\Users*\Documents\UiPath\HelloCmd\HelloCmd.1.0.2.nupkg"

Appreciate your quick response


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.