Run Parallel Process from local package

I need to start a parallel process and “Run Parallel Process” looks fantastic for what I need.
The problem is that I don’t know how to start a Parallel process that is stored in a local package (without orchestrator).
According to the documentation Run Parallel Process,process can be started from local packages.
Quote from doc. “Can be used to run local packages, as well as processes in Orchestrator, if a connection is available.”

Any idea?

Just to add some more details about my use case, I just want to start a process that runs in parallel while the main thread continues its execution.


1 Like

Hey @afeno

Where are you storing your local packages and could you please show the run parallel activity to see how you are passing ?


Hello @afeno

Got your requirement. Instead of running the process from the orchestrator, you need to run it from the local ryt. There was a similar question in the forum to invoke the process. But tried different solutions and it was throwing folder path not found.

Here the requirement is to invoke process from local instead of the orchestrator using invoke Process activity/Run parallel process. Any suggestions for this? How to pass the local folder path of the package?



The following might help you.

As only 1 foreground process can be run in the desktop, either of this process or starting process must be Background process, at least.


1 Like

Is this package published in the local or the process in orchestrator? If its a package in local folder, can you show the property that you set.

Calling a process in orchestrator is working fine with this activity and facing issue in calling the locally published packages.


Is this package published in the local or the process in orchestrator?

They are local published processes.

If its a package in local folder, can you show the property that you set.

It’s default settings, as the following. My environment is Studio 2021.10.5 service mode. I’ll try other version/mode.
→ Edit : In 22.4.0CE user mode it also works.

BTW, do you have any error?


Yes, What I tried is- published the package to a custom local folder and then provided that path of the nuget package.

I hope here you got the process in UiPATH Assistant when you run the process from Orchestrator and you were calling that process in the Uipath assistant using Invoke process. Is that correct?


My environment for the above is standalone. If robot service connects with OC, local published process cannot be run. I think this function is similar with UiRobot.exe execute --process. This means we can invoke the process which UiPath Assistant recognize only.



Yes…Even I’am also thinking the same .Thanks @Yoichi

@afeno I hope you got your answer

Thank you! I will add the process to UI Assistant and they call it with this name. Thanks. It works!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.