Use Invoke Process locally instead of Invoke Workflow


I’ve read in the documentation that we can use Invoke Process to run local packages if orchestrator is not connected. The problem, is that I tried to run my local processes using Invoke Process while orchestrator isn’t connected, but I wasn’t able to do it.
Is it even possible?
I can give some more explanation if needed.

Thanks in advance.

Hi @arthurz,
Can you show some screenshots of what you exactly want to achieve? Just for better understanding so I could try to help you.

Hi @Pablito,

This is related to my other question, so if only one of them is solved, it already helps me a lot.

Basically I’m trying to use ‘Invoke Process’ but providing the path of a local workflow, is it possible?


Yes you can use this activity to invoke local process and what even cooler you can invoke process directly from Orchestrator using this activity. Check here:

The Orchestrator Folder Path parameter does not work for processes executed by robots in classic folders. Only robots in modern folders have the ability to pass data outside of their folder.

So, if I want to use Orchestrator invoking xaml subroutines, I cannot use “Invoke workflow” and I need to use “invoke process” activity?


Yes, because the Invoke Workflow activity works only with workflows that are part of the process you are working on.

Thank you very much for you answer Pablito. At the end I have been able to run the project in Orchestrator in the same format as when I run it in my computer. The problem was not to use a “Invoke workflow” activity instead if a “invoke process” one, but it was in the Uipath Assistant since it assumed that all my integer arguments would take a value of 0 if I did not specify any value for them there, in the Uipath Assistant app. And that made the whole process go mad…

By the was. I cannot launch my project director in Orchestrator. It gets always pending. I can run it only from Assistant. And I cannot fix that.