Run from Studio hangs up randomly without any error or exception

Hello All,

I have a UiPath process built with REFramework which is accessing records from snowflake db and generating pdf files using MikTex framework.

In order to compile the pdf using MikTex, I use “Invoke powershell” activity inside a try catch block. I use a MikTex mode called nointeraction in my command, so that powershell will always return with the result and not wait for user interaction in case of errors.

The problem is , it is a very long running robot, and sometimes after it runs for an hour or so, the execution just stops randomly but always at this powershell activity. This activity does not also have a timeout in the configuration.
By execution, I mean locally running in studio and not via orchestrator.I havent tried with the orchestrator yet.

When I restart the bot without any changes, it just works and processes the same transaction without any problems.

I montiored the CPU usage when the problem comes up but the CPU usage is normal.
The machine harddisk space is also huge.
I am not sure where to even look, or how to handle this in the bot, as it does not give any error.

Any help is highly appreciated.

Thanks a lot in advance.


Hello @Kiruthika_Nithyanandan

Did you checked it in debug mode and plz share whats the error that you are error during failure

Hi @Rahul_Unnikrishnan ,

Thanks for your reply.
Unfortunately there is no error and when i run it for a few transactions in the debug mode it doesnt give any error.

I have a log message right above the Invoke powershell. That is getting printed.
The block of code is also inside a try catch block. And there is a log message in the catch. But this one is not printed at all.

Thanks and Regards,

Hi @Kiruthika_Nithyanandan,

Can you set up a try catch in your powershell command? If he gets an error, have him write it on a notepad. Maybe this will give some information about the problem.

In addition, look at the windows logs, you can check if there is an error that may be overloading at that time.


Hi @muhammedyuzuak ,

Thanks for your reply.
The invoke powershell is already in try catch block. The code never reaches the catch as the log message inside that never gets printed.

How can i check the windows logs?

Thanks and Regards,

Computer Management > Event Viewer


Hi @muhammedyuzuak ,

Thanks for the tip.
I checked the logs.
The first thing i found around the time the hang up occured is this:

  1. Beschreibung:

System.Net.Http.HttpRequestException: An error occurred while sending the request.
—> System.IO.IOException: The response ended prematurely.
at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, Boolean async, CancellationToken cancellationToken)
— End of inner exception stack trace —

And then two more immediately after

  1. Beschreibung:
    / finished with Stopped (was Cancelling)

2./ finished with Stopped (was Cancelling)
RemoteException wrapping System.Exception: Job was stopped (forced)!

Does it mean the process was stopped due to a break in internet connection?

Thanks a lot again for your help.

1 Like

Hi @Kiruthika_Nithyanandan,

I also checked the forum to be sure. It is recommended to create a ticket. They will also ask you for the logs again.

Additionally, I don’t know if you’ve tried it, maybe you can control it by removing the process and publishing it again.

I hope the problem will be fixed as soon as possible.

Hi @muhammedyuzuak,

The form post looks like the same problem. Thanks a lot for the link.
Unfortunately the version is community :(. Is it still possible to create a ticket?

What do you mean with removing an republishing a process? Does it mean I create a new process and upload this new copy to the orchestrator?

Thanks again for your help.