RPA process abort on SMTP mail

Hello, everyone,

we let the RPA processes send emails about the SMTP activity. In addition, we receive a status message in our organizational mail every 30 minutes so that we can see that the robot is still active.

Now it happens every 2-3 days at different times that the SMTP mail cannot be sent. So far we have started the RPA project again after a computer restart.

To fix the problem, we added a TryCatch to all SMTP activities so that the mail texts are written to a txt file. The txt file has just been written. However, the project hangs when the mail is subsequently sent without displaying an error or stopping the project. Sending mail only works again after restarting the computer.

Why could this be and what can we do about it?

Many thanks in advance.

Hey @Prisemuetchen

Kindly show some snap of the activity and it’s props used please…


If you are using Gmail, kindly try Gamil activiy to sent data.

Gokul Jai

Hello, I think it is a security issue at the Security options.
Personally I had added a second sccess key and it worked.
It requires a phone number, and I had received a security key.
It seems this is saved in the local credentials.
Now I don’t know sure, I didn’t try again.
Please see the next picture:

Hope it will help a lot. Adrian

Hello, everyone,

the problem could be solved with a current mail package version.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.