Send SMTP mail Message Activity does't complete or even doesnt timeout sometimes

Scenario: Send SMTP mail Message Activity doesn’t complete or even doesn’t timeout

This is random behavior.
but the strange thing is - send SMTP mail message activity doesn’t throw an exception or doesn’t’ timeout.

it just gets stuck. and this happens randomly.

has anyone else noticed this behavior?
any suggestions?

Any errors in logs?

No errors… it just gets stuck and then we have to kill manually…

What smtp server are you using?

we user Microsoft office365.com over standard port 587 with secure connection - StartTls
and also tried with auto.
Main problem here is that the activity doesn’t timeout or throwexception even after setting specified timeout duration, or even with default time out settings.

Was there ever a solution found for this?

HI, did you found the solution? Got the same problem

Any solution? I got the same problem.

Now. it just happened to me. the stuck only if smtp host using smtp.office365.com other smtp host is normal but my case it only happen on Attended Robot.

my local Studio enterprise is work perfectly.

version I used on both Robot and Studio is same 2020.4.3

please help

I want to update. I solved it by remove antivirus add-in on Outlook and restart.