Robot not running published workflow

Good day

We have the following situation. Created a workflow in developer and tested that it works and does what is required, works great. We then published the workflow and try to run it using the robot in the system tray. Robot starts and then after 3 seconds stops but nothing is done and no errors.

Any help would be appreciated.


@Massimo I think there is some dependencies in the project folder check it

Hi @Massimo,

Check that you have used any static path which is not accessible by the BOT, check all the packages are installed.

Are you trying to run in the same machine.

Add a detailed log mechanism to identify where it breaks.


How would i add a detailed log mechanism?

did this problem solve , coz i also got the same error

below is my log at least can any one view this and say why the similar problem is happening to me
01:26:00.9862 Info {“message”:“sample execution started”,“level”:“Information”,“logType”:“Default”,“timeStamp”:“2019-03-23T01:26:00.9842262+05:30”,“fingerprint”:“a9578dda-ab2a-457b-b453-3fbdc57efc25”,“windowsIdentity”:“DESKTOP-3BBQ4S9\Lenovo”,“machineName”:“DESKTOP-3BBQ4S9”,“processName”:“sample”,“processVersion”:“1.0.7021.2103”,“jobId”:“a2d75a0f-c0f0-47d9-ab29-11f85c92292b”,“robotName”:“LENOVO”,“machineId”:0,“fileName”:“Main”}
01:26:01.1970 Info {“message”:“sample execution ended”,“level”:“Information”,“logType”:“Default”,“timeStamp”:“2019-03-23T01:26:01.1970125+05:30”,“fingerprint”:“c50df095-1b13-46f0-bee0-8c8473535032”,“windowsIdentity”:“DESKTOP-3BBQ4S9\Lenovo”,“machineName”:“DESKTOP-3BBQ4S9”,“processName”:“sample”,“processVersion”:“1.0.7021.2103”,“jobId”:“a2d75a0f-c0f0-47d9-ab29-11f85c92292b”,“robotName”:“LENOVO”,“machineId”:0,“totalExecutionTimeInSeconds”:0,“totalExecutionTime”:“00:00:00”,“fileName”:“Main”}


What worked for us is we looked at all the processes again and one of the SQL processes had broken, which caused the automation to just stop.

1 Like