Robot Freezes IMAP/SMTP

Hallo, the robot always freezes on IMAP and SMTP after some time. After the IMAP retrieval I added a delay of 5 minutes. After restarting the PC it works again for a while. What can be the reason? The mail program is Lotus Notes.


Welcome to forums

Can you share more info that why you keep 5 minutes of dealy?
Also check If the memory consumption is taking while you are running the bot?


The delay was built in because too frequent IMAP queries can block the account. The robot runs into no error but freezes. It looks like it’s running, but it stops in one place and doesn’t continue.

Can you take a screen shot of the event viewer at the point when the robot freeze or see the UiPath logs? attach here, this can help to investigate.

Thanks. I’m currently on vacation for 2 weeks and will let you know when I’m back at work.

There is no entry for UiPath in the event manager. Where can I find the log file? We don’t have an orchestrator.

@Prisemuetchen What settings are you using for your STMP activity? if you’re using Office 365, are the firewall ports open to the entire scope of the IP range for O365? O365 has a large scope of IP ranges that reach the servers. DNS can take a while to roll through to a working one.

We have had similar issues with SMTP because we only had a limiting IP scope for O365 on corporate firewalls, so it would be a hit/miss on when it would reach an IP that goes through. Fixed it on our end by using PowerShell to determine open SMTP port for O365 and put host file on RPA computer pointing that IP to O365 SMTP and IMAP URLs. Dirty fix, but worked for us.

We use Lotus Notes as our mail program. The robot usually freezes after 4 hours.

Besides the event viewer, where can I see log data? We don’t have an orchestrator.

On the machine you run the process on, try C:\Users*username*\AppData\Local\UiPath\Logs This will contain some local log files, like Execution.log, Studio.log.

If you are using the IMAP or SMTP activity, the mail program installed is irrelevant, because the process uses the IMAP or SMTP connectivity settings embedded in the activity, bypassing the mail client.

Do you have a screen shot of your activity and its properties? Or can you attach the xaml?

Thanks, I found the log files. However, there are no errors included here that explain the freezing. The robot searches for orders in a continuous loop. If there is no job, it freezes on the 49th IMAP fetch. Until then, we will receive an email via SMTP every 15 minutes, so that we can see that the robot is still active. If there are orders, however, there are problems with SMTP, the robot freezes. A PDF should also be sent with an activity.

The data for the activities comes from the config file.

I was able to narrow down the problem now. Too frequent IMAP queries froze the robot. I have now adjusted this.

With SMTP, however, we still have the problem that the robot freezes when PDF files are to be sent. What can be the reason?

Interesting find; compliments on the IMAP freeze find.

I’m puzzled as to why the there are no credentials entered into Anmelden/Logon properties for the SMTP activities. I’ve had bad luck with Asset output as Secure (Password) string. To get around that, I’ve used for the regular Anmelden.Password property underneath Anmelden.Email property the following:

New System.Net.NetworkCredential(string.Empty,txt_Emailpasswort_RPA).Password

where txt_Emailpasswort_RPA is the name of the SecureString variable, assuming it is retrieved from a Credential Asset.