Robot connection failed, Orchestrator doesn't respond

Hello Community,

We’re using an on-prem Orchestrator and have configured some machines and robot accounts.

When we connect the first 5 robots with the Orchestrator, it works great. However, when we try to connect the 6th machine, it says the following:


After 5 to 10 seconds, it says this,


*Please ignore machine id

And right after that, the orchestrator stops responding and all other machines get disconnected. We’ve tried Redis caching and increasing the SQL Server pool size but didn’t work.

Not to mention that we have the appropriate number of licenses, the issue seems to be around the “connection limit”.

Appreciate all your help!


Hi @rizistt could you try with orchestrator url and machine key?

And also very the machine name should be host name while creating the machine.

Yeah, I did try that too, resulted in the same.


Found out the issue, this was caused by the Scalability settings. I disabled it and was able to get all of the machines connected.

Not sure why it’d react this way, but if someone knows how to modify SignalR settings (beyond that core dll config file), please share.