Retry Scope stopped working


I would highly appreciate your advice regarding my UIpath code problem.

I have a problem with the retry scope activity. I want the page to scroll down until it founds an element (empty checkmark), but when I run the code it stops after pressing only one “end” hotkey (it doesn’t retry - checkmark was not found). In NumberOfRetries field is number 3 and in RetryInterval: 1 sec

Just to mention, I have this empty check (condition element) under the “load more” field (same page) that if you scroll down to end page it automatically expands.

What should I do?


Hi @Chris_Balance

Did you tried the scroll down activity?

Hi @Chris_Balance

The seems like the empty checkmark that is indicated by the Element Exist activity is Present and the "Element Exist activity " will be True all the time as a result the “Hot key” is pressed only once.

Try indicating the element that is not present (which is False) and by scrolling down the element is present (which is True).

Or else you can use a Do While loop if you know how many times to send “End” hot key.


You can do it with the help of while loop.



@Chris_Balance Do you want to validate if the check box is checked or unchecked ? If yes, then please go through the below one

From what package I can get that scroll page or scroll activity?

Hey @Chris_Balance,

I am sorry I got confused with the maximized activity.

There is no such activity as of now.

Please try my other approach which I have mentioned above.

The problem is that checkbox is not showing on the first page layot. It has to scroll down and expand page with more results - search for empty checkbox. I don’t know exact number how many times it needs to scroll down, it depends where is empty box.

I’m new to this :smiley: Maybe you can show me any screenshot?

What did I do wrong?

@Chris_Balance Can you hover you mouse on the red mark and see what is the error showing ?

Any ideas how to solve maybe this solution? Now it scrolls down and never stops, probably something is wrong with ImageFound Activity.

@Chris_Balance It is not stopping the loop since it does not find the image

  • While loop always executes the activities until the condition becomes false
  • But, in your case the loop continues since it is not finding image (always imageFound = False it becoming true always)
  • Can you run the debug mode then check bot is entering in which block (then or else)

It is entering Then box. But I don’t know why its not stopping, because there were a lot of empty check boxes, but it didn’t stop the loop. I thought that maybe I wrote something wrong with ImageFound.


you can use the scroll activity, it search the element and scrolldown until it reach the element, please give a try.


Looks promising! Where can I get this “Mouse Scroll” activity?

there are two ways
first clicking the filter in activities panel and click show modern, then you it will appear
it will appear show modern for you

second is go to config of the project and enble the modern experience.


Thank you! But it doesn’t work : (

Which problem are you getting?

Hey @Chris_Balance,

Stick with this approach it should work.

Once the image is found use the break activity so the loop will break and the control will get outside of the loop.

Lets try this and let me know if you face any issues.

Meanwhile I will try it on my side and let you know if I found out anything else.