Requires User Interaction

Hello

Suddenly the processes stopped. I didn’t make any changes. When I enter the processes tab, I have an icon with the description Requires User Interaction next to each item. I have no idea what’s going on, please help! :frowning:Capture

1 Like

Same as me. It happens to me from exactly 00:00:00 25th Mar. Any advise for this ?

1 Like

Same me here. Is there any problem from UiPath side?

I have the same problem, somebody knows what is happening with the orchestrator

It seems something has been changed from 25th Mar 2020. I tried to send mail to UiPath Technical team but, no authority due to no licence nu#. I hope that this issue detected by UiPath team and reply to us…otherwise, I need to run it manually…

Ok, I know. Processes with robot Studio don’t work, but with Unattended everything is ok. Anyway I have this icon with the description Requires User Interaction on every process

Well, I think that this is totally intended. If you change your robot type from Studio to Unattended in the Robots Tab, scheduled Jobs Will trigger (if you select that robot when creating the schedule).
Uipath wants us to buy licences y think…

but why this icon appeared at every process ? :expressionless:

Maybe because of the structure of your process. It’s not that the process needs user interaction to trigger, but you have activities that cannot run on background or without a logged user.
I have some bots that can run on background, even if Windows is blocked due to no activity, but you (or the robot user) must be logged in with the robot user in that computer, even if you are working with another user logged in.
For example, I have robots running on user Roomba while I am logged in as Roomba and Arturo in the same computer, and i change users whenever I need to.

All my processes require “unlocking the account” because there are operations that cannot be carried out in the background. I understand that I don’t have to worry about this icon?

I think so, you don’t have to worry. I was using “Studio” robots and scheduled Jobs didn’t trigger. I’ve changed one of my machines to “Unattended” and the jobs are triggering normally, and that icon is present.
But I should wait for oficial feedback, that were just my thoughts

Ok…It’s only icon of type process… Each process have own icon. I try create for example Background process in Studio and after publish to Orchestrator it’s have different icon… :slight_smile:

Could you tell us if this problem has been solved? running as normal? coz, as I got alert from UiPath, Orchestrator doesn’t use the function of trigger or job but running only by unattended robot. Need some configuration to use it. Now, I am trying to configure it. Have you seen that notice?

Yes, my problem was solved. I understand everything now :slight_smile:

It’s good news. I also configured and now understood.

This icon appears to be controlled by the requiresUserInteraction property in the project.json file being true or false.

image image

image

It does not appear the documentation has been updated yet to detail the runtimeOptions https://docs.uipath.com/studio/v2020.4/docs/about-the-projectjson-file but it is mentioned briefly in the following document.

1 Like

Que pena la pregunta pero que configuraste y que entendiste, es que tengo el mismo problema y no he podido con eso. Agradezco la información que me puedas dar.

Ahora solo puedes usar bots desatendidos si quieres que el orquestador inicie tus procesos.
En tu tab “Robots” en “Administración” tienes que cambiar la configuración de uno de tus bots, de “Studio” a “Unattended”. Y podrás usarlo como hacías hasta ahora.

From now on, you need to use unattended robot in order for the orchestrator to run your processes.
In your Robots tab, from Managemente, you need to set one of your robots from Studio to Unattended and you will be able to uses as normal.