Replace Text (Word Application Scope) makes my text all Caps


#1

I am reading cells within an MS excel file and then replacing text in MS Word with the text pulled from the excel file. When I use the Replace text tool in the word application scope it makes my text all caps. For example, right before the replace text tool my text is ‘thousands’ but when the bot runs the text shows up as THOUSANDS in the word doc. I have tried adding ‘.ToLower’ to my variable but this does not fix my issue. My variable is formatted as a string.


#2

So, you are reading cell and there it is thousands and when you replace your text in word file you are Getting THOUSANDS.? can you check the replaced text in words in word file in lower or uppercase.?


#3

The words I am replacing in the Word file are ‘FN1101’.


#4

I can’t say I have much experience with Word automation.
But just out of curiosity, if you used the Replace manually by clicking on “Replace” under Editing section of the Home ribbon. Then, check the Formatting options…
image

Also make sure that the Font used in the Word file is not one that is all caps.

Just a couple ideas, like maybe the Replace Formatting options were set to All Caps for some reason.


#5

That is a good thought. I tried it but that did not fix it.