Replace Text in Document

I keep getting an error when using the replace text in Document activity in StudioX. The document is formatted like:
A. [A]
B. [B]
C. [C]
and so on. So I had to increment the alphabet and in the document it is searching for the letter in the brackets to replace with the text from Excel. It is saying the specified value is out of range, but it is replacing the text. I am using the community version of StudioX. I moved it over to Studio to see if I would get the same error and it is doing the same thing. It appears it is working, but it says out of range. Can someone tell me what I am doing wrong and how to correct it? I have attached copies of the code from Studio and StudioX also the excel sheet and word document showing the format and the changes made. Thank you



Are you filtering out the blank values? Or no from the input excel where you have the data?

Also can you try runnin gin debug and then open locals panel and check the exception details from locals panel in studio…that might give more indormation like what exactly is failing

Hope this helps


It is in an if statement, if the cell contains “EXPLAIN” then process, if not go to next row. In debug mode, it gives the correct value, but I am not seeing what range it is talking about?


If you open locals panel and check you would get more info…suggest check that …accordingly we cna think of the root cause and solution


I have a screenshot of the locals panel in the original question. Should I post a better one?


On the locals panel…go to exception details…and then open that and you will see a detailed exception there…


here is what it says under exception. Do you know what system not implemented exception is?


It means some class /method is missing…

Can you tru changing the word package version and try


Hi @meghan.myers ,

Could you try to use some other words for replacing and check if that works ?

Also noticed you are using the App Integration Word Activities, could you maybe also try with the WordDocument activities and check as well ? (Do not use this activity within the Word Application Scope)

Let us know if you do get the same error.

Thank you so much! That works.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.