RemoteException wrapping System.Exception: Error opening workbook. Make sure Excel is installed

I’m getting following error when dealing with Outlook or Excel activities.
RemoteException wrapping System.Exception: Error opening workbook. Make sure Excel is installed. —> RemoteException wrapping System.InvalidCastException: Unable to cast COM object of type ‘Microsoft.Office.Interop.Excel.ApplicationClass’ to interface type ‘Microsoft.Office.Interop.Excel._Application’. This operation failed because the QueryInterface call on the COM component for the interface with IID ‘{000208D5-0000-0000-C000-000000000046}’ failed due to the following error: Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).
I tried doing all possible work around like reinstallling MS Office, Clearing Registry for other version of MS Office etc. but the problem still persist.
I have MS Office 2013 installed. Can anyone shed some light on this please?

Hello @jaiprataph and welcome to the community!

Do you have Excel and Outlook installed on your computer? These activities rely on those application in order to work

Hello @srdjan.suc thanks for your response. Yes, MS Office 2013 is installed in my laptop and wonder why im getting this error. It was working fine with my old laptop and recently I got a new laptop, from then having this issue.
I have installed MS Office 64 bit as my OS is 64 bit as well.

Did you try disabling the Visible option on the Excel Application Scope?

@AndyMenon, thanks for your response. I have it disabled by default and still have this error coming up

Hi @jaiprataph
Refer this topic this might help you try to utilize those steps.

Fine
Welcome to uipath community
—in design tab -> manage packages -> in project dependencies -> uninstall Excel packages and re install it
—once after reinstalling restart the studio once and try executing the process again

Cheers @jaiprataph

hi @jitendra_123, thanks for sharing the post. I have tried this option already and does’nt seems to work

hi @Palaniyappan, tried uninstalling and reinstalling both excel activities package and interop, still no luck

Fine
Final call
Uninstall uipath studio and reinstall it pls
Cheers @jaiprataph

Downgraded my MS Office from 2013 to 2010 and this sorted out things. Strange but happy to live with this for now :slight_smile:

For anyone interested in the solution, please try this one here:

1 Like